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Введение
Библиотека блоков SimPowerSystems (в версии MATLAB 6.1 и более ранних – Power
System Blockset) является одной из множества дополнительных библиотек Simulink,
ориентированных на моделирование конкретных устройств. SimPowerSystems со#
держит набор блоков для имитационного моделирования электротехнических
устройств. В состав библиотеки входят модели пассивных и активных электро#
технических элементов, источников энергии, электродвигателей, трансформато#
ров, линий электропередачи и тому подобного оборудования. Имеется также раздел,
содержащий блоки для моделирования устройств силовой электроники, включая си#
стемы управления для них. Комбинируя возможности Simulink и SimPowerSystems,
пользователь может не только имитировать работу устройств во временной обла#
сти, но и выполнять различные виды анализа таких устройств. В частности,
пользователь имеет возможность рассчитать установившийся режим работы сис#
темы на переменном токе, выполнить расчет импеданса (полного сопротивления)
участка цепи, получить частотные характеристики, проанализировать устойчи#
вость, а также выполнить гармонический анализ токов и напряжений.

Несомненным достоинством SimPowerSystems является то, что сложные элект#
ротехнические системы можно моделировать, сочетая методы имитационного и
структурного моделирования. Например, силовую часть полупроводникового
преобразователя электрической энергии можно выполнить с использованием
имитационных блоков SimPowerSystems, а систему управления – с помощью
обычных блоков Simulink, отражающих лишь алгоритм ее работы, а не ее электри#
ческую схему. Такой подход, в отличие от пакетов схемотехнического моделиро#
вания, позволяет значительно упростить всю модель, а значит, повысить ее устой#
чивость и скорость работы. Кроме того, в модели с использованием блоков
SimPowerSystems (в дальнейшем SPS#модели) можно использовать блоки и ос#
тальных библиотек Simulink, а также функции самого MATLAB, что дает практи#
чески не ограниченные возможности для моделирования электротехнических си#
стем.

Библиотека SimPowerSystems достаточно обширна. В том случае, если все же
нужного блока в библиотеке нет, пользователь имеет возможность создать свой
собственный блок как с помощью уже имеющихся в библиотеке блоков, реализуя
возможности Simulink по созданию подсистем, так и на основе блоков основной
библиотеки Simulink и управляемых источников тока или напряжения.

Таким образом, SimPowerSystems в составе Simulink на настоящее время мо#
жет считаться одним из лучших пакетов для моделирования электротехнических
устройств и систем.
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1.1. Запуск системы
Для запуска программы Simulink необходимо предварительно запустить пакет
MATLAB. Рабочий стол системы MATLAB с командным окном показан на рис. 1.1.
Там же показана подсказка, появляющаяся в окне при наведении указателя мыши
на ярлык Simulink в панели инструментов.

Рис. 1.1. Рабочий стол системы MATLAB

После открытия основного окна программы MATLAB нужно запустить про#
грамму Simulink. Это можно сделать одним из трех способов:

нажать кнопку  (Simulink) на панели инструментов командного окна
MATLAB;
в строке командного окна MATLAB напечатать Simulink и нажать клавишу
Enter на клавиатуре;
выполнить команду Open… меню File и открыть файл модели (mdl#файл).

Последний способ предпочтителен при запуске уже готовой и отлаженной мо#
дели, когда требуется лишь провести моделирование и не нужно добавлять новые
блоки в модель. При применении двух первых способов открывается окно обозре#
вателя библиотеки блоков (рис. 1.2).

1.2. Обозреватель библиотеки блоков
Simulink
Окно обозревателя библиотеки блоков Simulink Library Browser содержит сле#
дующие элементы (рис. 1.2):

1. Заголовок с названием окна – Simulink Library Browser.
2. Меню с командами File, Edit, View, Help.
3. Панель инструментов с кнопками наиболее часто используемых команд меню.
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4. Окно комментария для вывода поясняющего сообщения о выбранном раз#
деле библиотеки или блоке.

5. Список разделов библиотеки.
6. Окно для вывода содержимого раздела библиотеки (список вложенных

разделов библиотеки или блоков).
7. Строка состояния, содержащая подсказку по выполняемому действию.
На рис. 1.2 выделена основная библиотека Simulink (в левой части окна) и по#

казаны ее разделы (в правой части окна).
Основная библиотека системы Simulink содержит следующие разделы:

Commonly Used Blocks – часто используемые блоки;
Continuous – блоки аналоговых элементов;
Discontinuities – нелинейные блоки;
Discrete – дискретные блоки;
Logic and Bit Operations – блоки логических и битовых операций;
Look�Up Tables – блоки таблиц;
Math Operations – блоки математических операций;
Model Verification – блоки верификации сигналов;
Model�Wide Utilities – раздел вспомогательных утилит;
Ports & Subsystems – порты и подсистемы;
Signal Attributes – блоки получения свойств сигналов;
Signal&Routing – блоки преобразования сигналов и вспомогательные блоки;
Sinks – приемники сигналов;
Sources – источники сигналов;
User�defined Function – функции пользователя;
Additional Math & Discrete.

Рис. 1.2. Обозреватель библиотеки блоков

Обозреватель библиотеки блоков Simulink
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Список разделов библиотеки Simulink представлен в виде дерева, и правила рабо#
ты с ним являются общими для списков такого вида: пиктограмма свернутого узла
дерева содержит символ «+», а пиктограмма развернутого содержит символ «–».

Для того чтобы развернуть или свернуть узел дерева, достаточно щелкнуть на
его пиктограмме левой клавишей мыши.

При выборе соответствующего раздела библиотеки в правой части окна ото#
бражается его содержимое (рис. 1.3).

Рис. 1.3. Отображение содержимого библиотеки
обозревателем блоков

Для работы с окном используются команды, собранные в меню. Меню обозре#
вателя библиотек содержит следующие пункты:

File (Файл) – работа с файлами библиотек;
Edit (Редактирование) – добавление блоков и их поиск (по названию);
View (Вид) – управление показом элементов интерфейса;
Help (Справка) – вывод окна справки по обозревателю библиотек.

Полный список команд меню обозревателя библиотек приведен в приложе#
нии 1.

Для работы с обозревателем можно также использовать кнопки на панели ин#
струментов (рис. 1.4).

Рис. 1.4. Кнопки панели инструментов обозревателя
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Кнопки панели инструментов имеют следующее назначение:

1. Создать новую Simulink#модель (открыть новое окно модели).
2. Открыть одну из существующих S#моделей.
3. Изменить свойство окна обозревателя «всегда сверху». После нажатия на

кнопку окно обозревателя будет отображаться поверх других открытых окон.
4. Найти блок, название которого (или первые несколько символов названия)

указано в расположенном справа от кнопки текстовом поле. Если требуе#
мый блок найден, в окне обозревателя открывается соответствующий раз#
дел библиотеки, а блок отображается как выбранный, в противном случае
в подокне комментария выводится сообщение Not found <имя блока>
(Блок <имя> не найден).

1.3. Создание модели
Для создания модели в среде SIMULINK необходимо последовательно выпол#
нить ряд действий:

1. Создать новый файл модели с помощью команды File ⇒ New ⇒ Model
(здесь и далее с помощью символа «⇒» указывается последовательность

вызова пунктов меню) или используя кнопку  на панели инструментов.
Вновь созданное окно модели показано на рис. 1.5.

Рис. 1.5. Пустое окно модели

2. Расположить блоки в окне модели. Для этого необходимо открыть соответ#
ствующий раздел библиотеки. Далее, указав курсором на требуемый блок и
нажав на левую клавишу мыши, «перетащить» блок в созданное окно. Кла#
вишу мыши нужно держать нажатой. На рис. 1.6 показано окно модели, со#
держащее блоки.
Для удаления блока необходимо выбрать блок (указать курсором на его
изображение и нажать левую клавишу мыши), а затем нажать клавишу
Delete на клавиатуре.

3. Далее, если это требуется, нужно изменить параметры блока, установлен#
ные по умолчанию. Для этого необходимо дважды щелкнуть левой клави#
шей мыши, указав курсором на изображение блока. Откроется окно редак#
тирования параметров данного блока. При вводе численных параметров

Создание модели
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следует иметь в виду, что в качестве десятичного разделителя должна ис#
пользоваться точка, а не запятая. После внесения изменений нужно за#
крыть окно кнопкой OK. Можно также, не закрывая окна, воспользоваться
кнопкой Apply для сохранения изменений. На рис. 1.7 в качестве примера
показаны блок, моделирующий передаточную функцию, и окно редактиро#
вания параметров данного блока.

Рис. 1.6. Окно модели с блоками

Рис. 1.7. Блок передаточной функции
и его окно параметров

4. После установки на схеме всех блоков требуется выполнить соединение
элементов схемы. Для этого необходимо указать курсором на «выход» бло#
ка, а затем нажать и, не отпуская левую клавишу мыши, провести линию ко
входу другого блока. После чего отпустить клавишу. Если соединение не
создано, то линия связи будет пунктирной и иметь красный цвет. В случае
правильного соединения линия связи будет сплошной. Для создания линии
связи можно также выделить блок#источник сигнала, затем нажать кла#
вишу Ctrl на клавиатуре и выделить блок#приемник. Для создания точки
разветвления в соединительной линии нужно подвести курсор к предпола#
гаемому узлу и, нажав правую клавишу мыши, протянуть линию. Для уда#
ления линии требуется выбрать линию, а затем нажать клавишу Delete на
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клавиатуре. Схема модели, в которой выполнены соединения между блока#
ми, показана на рис. 1.8.

Рис. 1.8. Готовая модель

5. После составления расчетной схемы необходимо сохранить ее в виде файла
на диске, выбрав пункт меню File ⇒ Save As... в окне схемы и указав папку
и имя файла. Следует иметь в виду, что имя файла не должно превышать
64 символов, должно начинаться с буквы и содержать только алфавитно#
цифровые символы латиницы и знак подчеркивания. Это же требование (за
исключением длины названия) относится и к пути файла. При последую#
щем редактировании схемы можно пользоваться пунктом меню File ⇒
Save. При повторных запусках программы SIMULINK загрузка схемы осу#
ществляется с помощью меню File ⇒ Open... в окне обозревателя библиоте#
ки или из командного окна системы MATLAB.

1.4. Основные элементы окна модели
Окно модели содержит следующие элементы (рис. 1.9):

1. Заголовок с названием окна. Вновь созданному окну присваивается имя
Untitled с соответствующим номером.

2. Панель меню – File, Edit, View, Simulation, Format, Tools и Help.
3. Панель инструментов.
4. Окно для создания схемы модели.
5. Строка состояния, содержащая информацию о текущем состоянии модели.

Меню окна содержит команды для редактирования модели, ее настройки и
управления процессом расчета, работы с файлами и т. п.:

File (Файл) – работа с файлами моделей;
Edit (Редактирование) – изменение модели и поиск блоков;
View (Вид) — управление показом элементов модели и интерфейса;
Simulation (Моделирование) – задание настроек для моделирования и
управление процессом расчета;
Format (Форматирование) – изменение внешнего вида блоков и модели
в целом;

Основные элементы окна модели
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Tools (Инструментальные средства) – применение специальных средств
для работы с моделью (отладчик, инструмент линейного анализа и т. п.);
Help (Справка) – открытие окна справочной системы.

Полный список команд меню окна модели приведен в приложении 2.
Для работы с моделью можно также использовать кнопки на панели инстру#

ментов (рис. 1.10).

Рис. 1.9. Основные элементы окна модели

Рис. 1.10. Панель инструментов окна модели

Кнопки панели инструментов имеют следующее назначение:

1. New Model – открыть новое (пустое) окно модели;
2. Open Model – открыть существующий файл модели (mdl#файл);
3. Save Model – сохранить файл на диске;
4. Print Model – вывод на печать схемы модели;
5. Cut – вырезать выделенную часть модели в буфер промежуточного хра#

нения;
6. Copy – скопировать выделенную часть модели в буфер промежуточного

хранения;
7. Paste – вставить в окно модели содержимое буфера промежуточного хра#

нения;
8. Undo – отменить предыдущую операцию редактирования;
9. Redo – восстановить результат отмененной операции редактирования;

10. Start/Pause/Continue Simulation – запуск модели на исполнение (команда
Start); после запуска модели на изображении кнопки выводится символ

, и ей соответствует уже команда Pause (приостановить моделирова#
ние). Для возобновления моделирования после паузы следует щелкнуть по
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той же кнопке, поскольку в режиме паузы ей соответствует команда Con�
tinue (Продолжить);

11. Stop – закончить моделирование. Кнопка становится доступной после на#
чала моделирования, а также после выполнения команды Pause;

12. Simulation Stop Time – время окончания моделирования. Позволяет задать
время окончания расчета;

13. Normal/Accelerator – обычный/ускоренный режим расчета. Инструмент
доступен, если установлено приложение Simulink Performance Tool;

14. Show when hovering – показывать значения сигналов на выходах блока при
наведении на блок указателя мыши;

15. Incremental Build – генерировать код для инструмента Real Time Workshop
(мастерская реального времени);

16. Refresh Model Blocks – обновить входные и выходные порты и параметры
всех блоков модели;

17. Update diagram – обновить окно модели;
18. Build Subsystem – создать исполняемый код подсистемы;
19. Library Browser – открыть окно обозревателя. Если обозреватель уже от#

крыт, то его окно будет выведено поверх всех остальных окон;
20. Launch model Explorer – открыть окно исследователя модели (инструмен#

та, систематизирующего информацию о модели);
21. Toggle Model Browser – открыть окно обозревателя модели. При использо#

вании данного инструмента в левой части окна модели будет открыто до#
полнительное окно, содержащее изображение иерархической структуры
модели в виде дерева;

22. Go to parent system – переход из подсистемы в систему высшего уровня
иерархии («родительскую систему»). Команда доступна, только если от#
крыта подсистема;

23. Debug – запуск отладчика модели.

В нижней части окна модели находится строка состояния, в которой отобража#
ются краткие комментарии к кнопкам панели инструментов, а также к пунктам
меню, когда указатель мыши находится над соответствующим элементом интер#
фейса. Это же текстовое поле используется и для индикации состояния Simulink:
Ready (Готов) или Running (Выполнение). В строке состояния отображаются
также:

масштаб отображения блок#диаграммы (в процентах, исходное значение
равно 100%);
индикатор степени завершенности сеанса моделирования (появляется пос#
ле запуска модели);
текущее значение модельного времени (выводится также только после за#
пуска модели);
используемый метод расчета состояний модели.

Основные элементы окна модели
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1.5. Основные приемы подготовки
и редактирования модели

Добавление текстовых надписей
Для повышения наглядности модели удобно использовать текстовые надписи.
Для создания надписи достаточно указать мышью место надписи и дважды щелк#
нуть левой кнопкой мыши. После этого появится блок надписи с курсором ввода.
Так же можно изменить и подписи к блокам моделей. Для этого нужно установить
мышь в область надписи и щелкнуть левой кнопкой мыши – в подписи появится
курсор ввода, и ее можно будет редактировать. На рис. 1.11 показаны текстовая
надпись и изменение надписи в блоке Transfer Function. Следует иметь в виду, что
только начиная с версии программы Simulink 6.5 (MATLAB 2006b) допустимо
использование кириллических шрифтов. Более ранние версии Simulink не адап#
тированы к их использованию, и применение таких шрифтов может иметь самые
разные последствия: отображение надписей в нечитаемом виде, обрезание надпи#
сей, сообщения об ошибках, а также невозможность открыть модель после ее со#
хранения. Поэтому применение надписей на русском языке для ранних версий
Simulink крайне не желательно.

Рис. 1.11. Создание текстовых надписей

Выделение объектов
Для выполнения какого#либо действия с элементом модели (блоком, соедини#
тельной линией, надписью) этот элемент необходимо сначала выделить. Выделе#
ние объектов удобнее всего осуществляется с помощью мыши. Для этого необхо#
димо установить курсор мыши на нужном объекте и щелкнуть левой кнопкой
мыши. Объект будет выделен. Об этом будут свидетельствовать маркеры по уг#
лам объекта (см. рис. 1.11). Можно также выделить несколько объектов. Для этого
требуется установить курсор мыши вблизи них, нажать левую кнопку мыши и,
удерживая ее, начать перемещать мышь. Появится пунктирная рамка, размеры
которой будут изменяться при перемещении мыши. Все охваченные рамкой
объекты становятся выделенными. Для выделения всех объектов в модели удобно
использовать команду Edit ⇒ Select All. После выделения объекта его можно ко#
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пировать или перемещать в буфер промежуточного хранения, извлекать из буфера,
а также удалять, используя стандартные приемы работы в Windows#программах.

Копирование и перемещение объектов
в буфер хранения
Для копирования объекта в буфер его необходимо предварительно выделить,

а затем выполнить команду Edit ⇒ Copy или воспользоваться инструментом 
на панели инструментов.

Для вырезания объекта в буфер его необходимо предварительно выделить,
а затем выполнить команду Edit ⇒ Cut или воспользоваться инструментом  на
панели инструментов. При выполнении данных операций следует иметь в виду,
что объекты помещаются в собственный буфер MATLAB и недоступны из других
приложений. Использование команды Edit ⇒ Copy model to Clipboard позволяет
поместить графическое изображение модели в буфер Windows и, соответственно,
делает его доступным для остальных программ.

Копирование можно выполнить и таким образом: нажать правую клавишу
мыши и, не отпуская ее, переместить объект. При этом будет создана копия объек#
та, которую можно переместить в необходимое место.

Вставка объектов из буфера хранения
Для вставки объекта из буфера необходимо предварительно указать место встав#
ки, щелкнув левой клавишей мыши в предполагаемом месте вставки, а затем вы#
полнить команду Edit ⇒ Paste или воспользоваться инструментом  на панели
инструментов.

Удаление объектов
Для удаления объекта его необходимо предварительно выделить, а затем выпол#
нить команду Edit ⇒ Clear или воспользоваться клавишей Delete на клавиатуре.
Нужно помнить, что команда Clear удаляет блок без помещения его в буфер обме#
на. Однако эту операцию можно отменить командой меню File ⇒ Undo.

Соединение блоков
Для соединения выхода одного блока со входом другого курсор мыши устанавли#
вается на выходе блока, от которого должно исходить соединение. При этом кур#
сор превращается в большой крест из тонких линий (рис. 1.12). Держа нажатой
левую кнопку мыши, необходимо переместить курсор ко входу следующего бло#
ка, где курсор мыши приобретет вид креста из тонких сдвоенных линий
(рис. 1.13). Добившись протяжки линии ко входу следующего блока, следует от#
пустить левую кнопку мыши. Соединение будет завершено, и в конце его появит#
ся жирная стрелка.

Основные приемы подготовки и редактирования модели
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Созданную линию можно выделить, признаком чего будут квадратные марке#
ры, расположенные в узловых точках соединительной линии (см. рис. 1.14). Для
выделенной линии доступны те же операции, что и для блоков модели: удаление,
перемещение, копирование в буфер промежуточного хранения и т. д.

Иногда требуется сделать петлю соединительной линии в ту или иную сторо#
ну. Для этого нужно захватить фрагмент линии и отвести его в нужную сторону,
перемещая мышь с нажатой левой кнопкой. Рисунок 1.14 поясняет этот процесс.

Изменение размеров блоков
Для изменения размера блока он выделяется, после чего курсор мыши необходи#
мо установить на один из маркеров по углам блока. Как только курсор мыши пре#
вратится в двунаправленную диагональную стрелку, можно будет при нажатой

Рис. 1.12. Начало проведения линии

Рис. 1.13. Завершение проведения линии

Рис. 1.14. Создание петли линии
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левой кнопке растягивать блок по диагонали, увеличивая или уменьшая его раз#
меры (см. рис. 1.15). При этом изменяется только графическое изображение бло#
ка, а размеры его названия в виде текстовой надписи остаются прежними.

Рис. 1.15. Изменение размеров блока

Перемещение блоков и вставка блоков
в соединение
Блок, участвующий в соединении, можно перемещать в окне модели, выделив его и
перетаскивая, как обычно, мышью. При этом соединение не разрывается, а просто
сокращается или увеличивается в длине. В длинное соединение можно вставить
новый блок, поместив его в нужном месте линии. Такая вставка возможна лишь для
блоков, имеющих один вход и один выход, которые включаются в соединение.

Использование команд Undo и Redo
В процессе освоения программы пользователь может совершать действия, кажу#
щиеся на первый взгляд необратимыми (например, случайное удаление части мо#
дели, наложение блоков друг на друга при копировании и т. д.). В этом случае
следует воспользоваться командой Undo – отмена последней операции. Команду
можно вызвать с помощью кнопки  в панели инструментов окна модели или из
меню Edit. Для восстановления отмененной операции служит команда Redo (ин#
струмент ).

Форматирование объектов
В меню Format (так же как и в контекстном меню, вызываемом нажатием правой
клавиши мыши на объекте) находится ряд команд форматирования блоков. Их
можно разделить на несколько характерных групп.

1. Управление отображением надписей и видом блоков:
Enable TeX commands – включить выполнение специальных текстовых
команд для отображения математических символов, греческих букв и т. п.;
Text alignment – выравнивание текста в текстовом блоке;

Основные приемы подготовки и редактирования модели
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Flip name – помещение подписи блока сверху или снизу блока;
Show/Hide name – отображение или скрытие подписи выделенного
блока;
Show drop shadow – показ тени от блока;
Show port labels – показ меток портов.

2. Установка цветов:
Foreground color – установка цвета линий выделенных блоков;
Background color – установка цвета фона для выделенных блоков;
Screen color – установка цвета фона для всего окна модели.

3. Изменение положения блока:
Flip block – зеркальное отображение относительно вертикальной оси
симметрии;
Rotate block – поворот блока на 90° по часовой стрелке.

4. Форматирование надписей. Команда Format ⇒ Font выводит окно с уста#
новками шрифта для текстовых надписей, позволяющее изменять вид
шрифта надписи, размер шрифта, начертание и тому подобные параметры
надписи.

5. Прочие установки:
Library link display – отображение связей с библиотеками;
Sample time colors – установка цвета блока индикации времени;
Wide nonscalar lines – увеличение/уменьшение ширины нескалярных
линий;
Signal dimensions – отображение размерности сигналов;
Port data types – вывод данных о типе портов;
Storage class – класс памяти. Параметр, устанавливаемый при работе
Real#Time Workshop;
Execution order – вывод порядкового номера блока в последовательно#
сти исполнения.

1.6. Установка параметров
моделирования и его выполнение
Перед выполнением расчетов необходимо предварительно задать параметры
расчета. Задание параметров расчета выполняется в панели управления меню
Simulation ⇒ Configuration Parameters. Вид панели управления приведен на
рис. 1.16.

В левой части панели управления находится список групп настраиваемых
параметров. При выборе какой#либо группы параметров в левой части окна по#
является панель, позволяющая изменять параметры данной группы. Установка
параметров моделирования выполняется с помощью элементов управления, раз#
мещенных в панели Solver (Решатель). Эти элементы разделены на две группы
(рис. 1.16): Simulation time (Интервал моделирования) и Solver options (Пара#
метры расчета).
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Установка параметров расчета модели
Simulation time:

[интервал моделирования]. Величина интервала моделирования задается с по#
мощью указания начального (Start time) и конечного (Stop time) значений време#
ни расчета. Начальное время, как правило, задается равным нулю. Величина ко#
нечного времени задается пользователем исходя из условий решаемой задачи.

Solver options:
[параметры решателя]. При выборе параметров решателя необходимо указать

метод интегрирования (Type) либо с фиксированным (Fixed#step), либо с пере#
менным (Variable#step) шагом. Как правило, Variable#step используется для моде#
лирования непрерывных систем, а Fixed#step – для дискретных.

Можно выбрать один из следующих методов:

ode45 – одношаговые явные методы Рунге#Кутта 4#го и 5#го порядка;
ode23 – одношаговые явные методы Рунге#Кутта 2#го и 3#го порядка;
ode113 – многошаговый метод Адамса#Башворта#Мултона переменного
порядка;
ode15s – многошаговый метод переменного порядка (от 1 до 5), использую#
щий формулы численного дифференцирования;
ode23s – одношаговый метод, использующий модифицированную формулу
Розенброка 2#го порядка;
ode23t – метод трапеций с интерполяцией;
ode23tb – неявный метод Рунге#Кутта в начале решения и метод, исполь#
зующий формулы обратного дифференцирования 2#го порядка в после#
дующем.

Рис. 1.16. Окно настройки параметров расчета

Установка параметров моделирования и его выполнение
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Содержимое панели Configuration Parameters может меняться в зависимости
от выбранного метода интегрирования и решателя. Основные параметры решате#
лей для разных методов интегрирования приведены ниже:

Мах step size – максимальный шаг интегрирования. По умолчанию он
устанавливается автоматически (auto), и его значение в этом случае равно
(StopTime – StartTime)/50. Довольно часто это значение оказывается
слишком большим, и наблюдаемые графики представляют собой ломаные,
а не плавные линии. В этом случае величину максимального шага расчета
необходимо задавать явным образом;
Мin step size – минимальный шаг интегрирования;
Initial step size – начальное значение шага интегрирования;
Zero crossing control – контроль пересечения нулевого уровня. Значение
параметра выбирается из списка: Use local setting (Использовать настройки
блоков), Enable on (Включить для всех блоков), Disable on (Выключить для
всех блоков). Параметр позволяет управлять точностью расчета при пере#
сечении сигналами нулевого уровня. При отключении Zero crossing control
может быть существенно повышена скорость расчета, но будет снижена
точность;
Relative tolerance – относительная погрешность;
Absolute tolerance – абсолютная погрешность;
Fixed step size – фиксированный шаг расчета. Параметр доступен при вы#
боре метода интегрирования с фиксированным шагом.

Выполнение расчета
Запуск расчета выполняется с помощью выбора пункта меню Simulation ⇒ Start.
или инструмента  на панели инструментов. Процесс расчета можно завершить

досрочно, выбрав пункт меню Simulation/Stop или инструмент . Расчет также
можно остановить (Simulation ⇒ Pause) и затем продолжить (Simulation ⇒
Continue).

Завершение работы
Для завершения работы необходимо сохранить модель в файле, закрыть окно мо#
дели, окно обозревателя библиотек, а также командное окно пакета MATLAB.
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2.1. Источники сигналов Sources
1. Constant – источник постоянного сигнала.
2. Sine Wave – источник синусоидального сигнала.
3. Ramp – источник линейно#изменяющегося воздействия.
4. Step – генератор ступенчатого сигнала.
5. Signal Generator – генератор сигналов.
6. Uniform Rundom Number – источник случайного сигнала с равномерным

распределением.
7. Random Number – источник случайного сигнала с нормальным распреде#

лением.
8. Pulse Generator – источник импульсного сигнала.
9. Chirp Signal – генератор линейно#изменяющейся частоты.

10. Band�Limited White Noise – генератор белого шума.
11. Clock – источник времени.
12. Digital Clock – дискретный источник времени.
13. From File – блок считывания данных из файла.
14. From Workspace – блок считывания данных из рабочей области MATLAB.
15. Ground – формирователь сигнала нулевого уровня.
16. Repeating Sequence – источник периодического сигнала.
17. Inport – входной порт.
18. Signal Builder – конструктор сигналов.
19. Repeating Sequence Stair – источник ступенчатого периодического сигнала.
20. Repeating Sequence Interpolated – источник периодического сигнала с ин#

терполяцией.
21. Counter Free�Running – источник сигнала типа «счетчик».
22. Counter Limited – источник типа «счетчик c ограничением».

2.2. Приемники сигналов Sinks
1. Scope – осциллограф.
2. Floating Scope – «плавающий» осциллограф.
3. XY Graph – графопостроитель.
4. Display – цифровой дисплей.
5. Stop Simulation – блок остановки моделирования.
6. To File – блок записи в файл.
7. To Workspace – блок записи в рабочую область MATLAB.
8. Terminator – концевой приемник.
9. Outport – выходной порт.

2.3. Блоки непрерывных моделей
Continuous

1. Derivative – блок вычисления производной.
2. Integrator – интегратор.
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3. Transport Delay – блок фиксированной задержки сигнала.
4. Variable Transport Delay – блок управляемой задержки сигнала.
5. Transfer Fcn – передаточная функция.
6. Zero�Pole – передаточная функция «нули#полюса».
7. State�Space – объект пространства состояний.

2.4. Блоки дискретных моделей
Discrete

1. Unit Delay – единичная дискретная задержка.
2. Zero�Order Hold – экстраполятор нулевого порядка.
3. First�Order Hold – экстраполятор первого порядка.
4. Discrete�Time Integrator – дискретный интегратор.
5. Discrete Transfer Fcn – дискретная передаточная функция.
6. Discrete Zero�Pole – дискретная передаточная функция «нули#полюса».
7. Discrete Filter – дискретный фильтр.
8. Discrete State�Space – дискретный объект пространства состояний.
9. Memory – блок задержки на один расчетный шаг.

10. Integer Delay – блок задержки дискретного сигнала на n расчетных шагов.
11. Tapped Delay – блок задержки дискретного сигнала на n расчетных шагов

с выводом всех задержанных сигналов.
12. Difference – блок вычисления приращения сигнала за один расчетный шаг.
13. Discrete Derivative – блок вычисления производной дискретного сигнала.
14. Transfer Fcn First Order – дискретная передаточная функция первого по#

рядка.
15. Transfer Fcn Lead or Lag – передаточная функция, компенсирующая за#

держку или опережение сигнала.
16. Transfer Fcn Real Zero – передаточная функция с действительными нулями.
17. Weighted Moving Average – блок вычисления скользящего среднего значе#

ния входного сигнала с учетом весовых коэффициентов.

2.5. Нелинейные блоки Discontinuities
1. Saturation – ограничитель.
2. Dead Zone – зона нечувствительности.
3. Relay – реле.
4. Rate Limiter – блок ограничения скорости изменения сигнала.
5. Quantizer – квантователь.
6. Coulomb and Viscous Friction – блок сухого и вязкого трения.
7. Backlash – люфт.
8. Hit Crossing – блок определения момента пересечения порогового зна#

чения.
9. Saturation Dynamic – управляемый ограничитель.

10. Dead Zone Dynamic – управляемая зона нечувствительности.

Нелинейные блоки Discontinuities
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11. Rate Limiter Dynamic – управляемый блок ограничения скорости измене#
ния сигнала.

12. Wrap To Zero – блок, выполняющий сброс сигнала до нулевого уровня.

2.6. Блоки математических операций
Math Operations

1. Abs – блок вычисления модуля.
2. Sum – сумматор (пиктограмма в виде окружности).
3. Product – умножитель.
4. Sign – определитель знака.
5. Gain, Matrix Gain – усилитель.
6. Slider Gain – ползунковый регулятор.
7. Dot Product – блок скалярного умножения векторов.
8. Math Function – математическая функция.
9. Trigonometric Function – тригонометрическая функция.

10. Complex to Real�Image – блок вычисления действительной и (или) мнимой
части комплексного числа.

11. Complex to Magnitude�Angle – блок вычисления модуля и (или) аргумента
комплексного числа.

12. Real�Image to Complex – блок расчета комплексного числа по его действи#
тельной и мнимой части.

13. Magnitude�Angle to Complex – блок расчета комплексного числа по его мо#
дулю и аргументу.

14. MinMax – блок вычисления максимального или минимального значения.
15. Rounding Function – блок округления числа.
16. Algebraic Constraint – блок алгебраического контура.
17. Assignment – блок присвоения элементам массива новых значений.
18. Matrix Concatenation – блок объединения сигналов в матрицу.
19. Reshape – преобразователь размерности сигнала.
20. Polynomial – степенной многочлен.
21. Add – сумматор (пиктограмма в виде прямоугольника).
22. Subtract – блок вычисления разности.
23. Sum of Elements – блок вычисления суммы элементов вектора.
24. Bias – смещение.
25. Product of Elements – блок вычисления произведения элементов вектора.
26. Weighted Sample Time Math – блок поддержки вычислений, использую#

щих шаг дискретизации.
27. Divide – блок деления.
28. Unary Minus – унарный минус.
29. MinMax Running Resettable – блок вычисления максимального или мини#

мального значения с возможностью сброса.
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30. Sine Wave Function – синусоидальная функция.

2.7. Блоки маршрутизации сигналов
Signal&Routing

1. Mux – мультиплексор.
2. Demux – демультиплексор.
3. Bus Creator – шинный формирователь.
4. Bus Selector – шинный селектор.
5. Selector – селектор.
6. Merge – объединитель сигналов.
7. Goto – блок передачи сигнала.
8. From – блок приема сигнала.
9. Goto Tag Visibility – блок признака видимости сигнала.

10. Data Store Memory – блок создания общей области памяти.
11. Data Store Write – блок записи в именованную область памяти.
12. Data Store Read – блок считывания из именованной области памяти.
13. Switch – переключатель.
14. Multiport Switch – многовходовой переключатель.
15. Manual Switch – ручной переключатель.
16. Bus Assignment – блок, выполняющий замену сигнала в шине.
17. Environment Controller – контроллер среды.
18. Index Vector – переключатель элементов вектора.

2.8. Блоки определения свойств
сигналов Signal Attributes

1. Data Type Conversion – преобразователь типа сигнала.
2. Width – блок определения размерности сигнала.
3. IC – блок установки начального значения.
4. Signal Specification – блок проверки спецификаций сигнала.
5. Probe – датчик свойств сигнала.
6. Rate Transition – блок согласования дискретных сигналов.
7. Data Type Duplicate – проверка совпадения типа данных.
8. Data Type Propagation – преобразование типа сигнала в соответствии с ти#

пом образцового сигнала.
9. Data Type Scaling Strip – масштабирование сигнала с фиксированной точкой.

10. Data Type Conversion Inherited – преобразование типа входного сигнала.
11. Signal Conversion – преобразование векторного сигнала.
12. Weighted Sample Time – блок определения величины шага дискретизации

(вариант блока Weighted Sample Time Math).

Блоки определения свойств сигналов Signal Attributes
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2.9. Блоки задания таблиц Look0Up
Tables

1. Look�Up Table – одномерная таблица.
2. Look�Up Table (2D) – двумерная таблица.
3. Look�Up Table (n�D) – многомерная таблица.
4. Direct Look�Up Table (n�D) – многомерная таблица с прямым доступом

к элементам.
5. PreLook�Up Index Search – блок обработки индексов.
6. Interpolation (n�D) using PreLook�Up – блок интерполяции табличной

функции.
7. Lookup Table Dynamic – одномерная таблица. Табличные данные задаются

внешними сигналами.
8. Sine – табличная функция sin.
9. Cosine – табличная функция cos.

2.10. Функции, определяемые
пользователем User0defined Function

1. Fcn – блок задания функции.
2. MATLAB Fcn – блок задания MATLAB#функции.
3. S�function – S#функция.
4. S�Function Builder – конструктор S#функции на языке С.
5. Embedded MATLAB Function – вложенная MATLAB#функция.
6. Level�2 M�file S�Function – блок задания S#функции второго уровня.

2.11. Порты и подсистемы Ports &
Subsystems

1. Subsystem, Atomic Subsystem – виртуальная и неделимая подсистемы.
2. Enabled Subsystem, Enabled – управляемая наличием сигнала подсистема

и ее блок управления.
3. Triggered Subsystem, Trigger – управляемая фронтом сигнала подсистема

и ее блок управления.
4. Enabled and Triggered Subsystem – управляемая уровнем и фронтом сигна#

ла подсистема.
5. Function�Call Subsystem – управляемая функцией подсистема и ее блок

управления.
6. Function�Call Generator – внешний блок управления FC#подсистемой.
7. If – блок условного оператора.
8. Switch Case – блок переключателя.
9. If Action Subsystem – управляемая условием подсистема.

10. Switch Case Action Subsystem – переключаемая подсистема.
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11. For Iterator Subsystem – управляемая циклом For подсистема.
12. While Iterator Subsystem – управляемая циклом While подсистема.
13. Configurable Subsystem – переконфигурируемая подсистема.
14. CodeReuse Subsystem – подсистема, имеющая общий код для всех ее эк#

земпляров в модели.
15. Model – блок, обеспечивающий подключение файла к текущей модели.
16. In – входной порт.
17. Out – выходной порт.

2.12. Блоки верификации сигналов
Model Verification

1. Check Static Lower Bound – блок контроля минимального уровня сигнала.
2. Check Static Upper Bound – блок контроля максимального уровня сигнала.
3. Check Static Range – блок контроля сигнала внутри зоны.
4. Check Static Gap – блок контроля сигнала вне зоны.
5. Check Dynamic Lower Bound – блок контроля динамического минималь#

ного уровня сигнала.
6. Check Dynamic Upper Bound – блок контроля динамического максималь#

ного уровня сигнала.
7. Check Dynamic Range – блок контроля сигнала внутри динамической

зоны.
8. Check Dynamic Gap – блок контроля сигнала вне динамической зоны.
9. Assertion – блок проверки сигнала на нулевое значение.

10. Check Discrete Gradient – блок контроля градиента дискретного сигнала.
11. Check Input Resolution – блок проверки разрешения входного сигнала.

2.13. Библиотека дополнительных
утилит Model0Wide Utilities

1. Model Info – информационный блок.
2. DocBlock – блок документации.
3. Timed�Based Linearization – блок линеаризации для заданного момента

времени.
4. Trigger�Based Linearization – блок линеаризации для момента времени, за#

данного управляющим сигналом.

2.14. Блоки логических операций
Logic and Bit Operations

1. Bitwise Operator – блок побитовых логических операций.
2. Combinatorial Logic – блок комбинаторной логики.
3. Logical Operator – блок логической операции.

Logic and Bit Operations



34 Обзор основной библиотеки Simulink

4. Relational Operator – блок вычисления операции отношения.
5. Interval Test – блок, определяющий, что значение входного сигнала нахо#

дится в заданном интервале.
6. Interval Test Dynamic – блок, определяющий, что значение входного сигна#

ла находится в заданном интервале. Значение интервала задается внешни#
ми сигналами.

7. Compare To Zero – сравнение с нулем.
8. Compare To Constant – сравнение с константой.
9. Bit Set – блок устанавливает указанный бит целого числа равным 1.

10. Bit Clear – блок устанавливает указанный бит целого числа равным 0.
11. Shift Arithmetic – сдвиг числа в двоичном представлении.
12. Extract Bits – извлечение битов двоичного числа.
13. Detect Increase – обнаружение увеличения сигнала.
14. Detect Decrease – обнаружение уменьшения сигнала.
15. Detect Change – обнаружение изменения сигнала.
16. Detect Rise Positive – обнаружение увеличения положительного сигнала.
17. Detect Rise Nonnegative – обнаружение увеличения неотрицательного

сигнала.
18. Detect Fall Negative – обнаружение уменьшения отрицательного сигнала.
19. Detect Fall Nonpositive – обнаружение уменьшения неположительного

сигнала.

2.15. Часто используемые блоки
Commonly Used Blocks
Библиотека включает наиболее часто используемые пользователями блоки из
других библиотек (Constant, Step, Sum, Scope, Gain и т. д.).

2.16. Дополнительные
математические и дискретные блоки
Additional Math & Discrete
Библиотека содержит два раздела: Additional Discrete (Дополнительные диск#
ретные блоки) и Increment/Decrement (Блоки «Приращение/Уменьшение»).
В первом разделе находятся дополнительные блоки дискретных передаточных
функций и разного вида блоки задержки сигналов. Во втором разделе находятся
блоки, увеличивающие и уменьшающие значение сигналов на фиксированную
величину.
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